IP.Board 4 Upgrades: Click here to keep updated on the status of each upgrade.

Jump to content


Welcome to DevFuse Forums


Sign In  Log in with Facebook

Create Account
Welcome to DevFuse Forums, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of DevFuse Forums by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.
 
Guest Message by DevFuse

(View All Products)Featured Products

  • Donation Tracker


    Help fund your forum with donations, setup goals and track member donations. Offer rewards for members donating.
  • Timeslip System


    Have your members submit their race times and share with others. Intergrates with our Garage System.
  • Videos System


    Allows your members to submit their own videos for community viewing. Support is included for all the major video sites.
  • Garage System


    Setup a community Garage when members add their own vehicles with images and modifications.
  • Form Manager


    Build your own forms for your members without coding experience. Support included for pm, email and topics.
  • Collections System


    Build a community database of items for your members. Full features custom fields included.

Photo

uPortal image resize issue


  • Please log in to reply
11 replies to this topic

#1 highlander

highlander

    Advanced Member

  • Customers
  • 91 posts
  • Gender:Male
  • IP.Board Version:IPB 3.2.x

Posted 07 March 2011 - 06:54 AM

I can get images to resize in the regular post, but uportal will not resize...

Is there a way we can make uportal resize images to either column width or a specified maximum width? Or to follow the posts settings on ACP?

Thanks

#2 Michael

Michael

    Management

  • Management
  • 3,316 posts
  • Gender:Male
  • IP.Board Version:IPB 3.4.x

Posted 08 March 2011 - 02:59 AM

Is this for an attachment or external image?

IP.Board 4 Upgrades - Check on the status of my modification upgrades here. (Looking for beta testers)


#3 KiLaTeS

KiLaTeS

    Member

  • Members
  • PipPip
  • 12 posts
  • IP.Board Version:IPB 3.1.x

Posted 08 March 2011 - 03:17 PM

that happen to me also, its on an external image if is the same problem as me... I always edit the images and make them smaller before I post... but if there is anything that can be fixed... will be apreciated :)

#4 Michael

Michael

    Management

  • Management
  • 3,316 posts
  • Gender:Male
  • IP.Board Version:IPB 3.4.x

Posted 08 March 2011 - 08:46 PM

I've only tested this with the inbuilt "News" settings from uPortal but should resize those external images.

Open Admin CP > Look & Feel Tab > select skin > skin_uportal > portal_end.

Find:
</table>

Add BELOW:
<script type='text/javascript'>
ipb.vars['image_resize'] = {parse expression="intval($this->settings['resize_linked_img'])"};
ipb.global.post_width	 = 500;
	// Resize images
	$$('.post', '.poll').each( function(elem){
		ipb.global.findImgs( $( elem ) );
	});
</script>

Save.

Open Admin CP > Look & Feel Tab > select skin > skin_uportal > news_block.

Find:
<td class='row2'><if test="limitNewsHeight:|:$newsforum_height==1">

Replace With:
<td class='post'><if test="limitNewsHeight:|:$newsforum_height==1">

Save.

IP.Board 4 Upgrades - Check on the status of my modification upgrades here. (Looking for beta testers)


#5 highlander

highlander

    Advanced Member

  • Customers
  • 91 posts
  • Gender:Male
  • IP.Board Version:IPB 3.2.x

Posted 03 June 2012 - 05:12 PM

hm..... no worky :(

#6 Michael

Michael

    Management

  • Management
  • 3,316 posts
  • Gender:Male
  • IP.Board Version:IPB 3.4.x

Posted 06 June 2012 - 12:01 AM

Tried with external images? I think this was for IPB 3.1, not tested with 3.2. Do I still have access on your site? I can add the edits and test.

IP.Board 4 Upgrades - Check on the status of my modification upgrades here. (Looking for beta testers)


#7 highlander

highlander

    Advanced Member

  • Customers
  • 91 posts
  • Gender:Male
  • IP.Board Version:IPB 3.2.x

Posted 06 June 2012 - 05:04 PM

Yes you still have access... currently fixing all the stuff for uportal and group color mod!!! oh god...

Try to do a test with photobucket which is what I use and what most people use!

#8 highlander

highlander

    Advanced Member

  • Customers
  • 91 posts
  • Gender:Male
  • IP.Board Version:IPB 3.2.x

Posted 06 June 2012 - 05:27 PM

Done... Group format now accurately appears on uportal!!!!!!!!!

#9 Michael

Michael

    Management

  • Management
  • 3,316 posts
  • Gender:Male
  • IP.Board Version:IPB 3.4.x

Posted 06 June 2012 - 09:28 PM

Yes you still have access...


Sorry too many pms, would you mind sending me a pm. Bit busy now but should have some time before the weekend to take a look.

IP.Board 4 Upgrades - Check on the status of my modification upgrades here. (Looking for beta testers)


#10 highlander

highlander

    Advanced Member

  • Customers
  • 91 posts
  • Gender:Male
  • IP.Board Version:IPB 3.2.x

Posted 12 June 2012 - 10:40 PM

Were you able to check?

Thanks a bunch!!!!!

#11 Michael

Michael

    Management

  • Management
  • 3,316 posts
  • Gender:Male
  • IP.Board Version:IPB 3.4.x

Posted 14 June 2012 - 12:56 AM

Looks like the code I'm using was removed in IPB 3.3.x. This is now a setting in the admin cp "Automatic resize image force size". If you enter 300, it would then limit external images to 300px x 300px.

IP.Board 4 Upgrades - Check on the status of my modification upgrades here. (Looking for beta testers)


#12 highlander

highlander

    Advanced Member

  • Customers
  • 91 posts
  • Gender:Male
  • IP.Board Version:IPB 3.2.x

Posted 17 June 2012 - 12:39 AM

Thanks... entered 640, we'll see how it goes!!!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users