Jump to content
DevFuse Forums
Due to a family and medical emergency, support has been delayed and will be delayed for the next few weeks. I'm sorry for those who have been waiting and will try my hardest to reply to everyone as soon as possible.
Michael

Videos System v2.3.1 Update

Recommended Posts

the portal add-on

 

You can add the Videos Global Box to the Portal Addon if you check the Extras/Add Portal Block.html. That's what your trying to do? If not, you'll need to be a little bit clearer.

Share this post


Link to post
Share on other sites

Sorry Chris, I'm a complete idiot, Kept on reading that but was thinking about something completely different. Below is the code for either.

 

Global Hook

<?php
			 require_once( IPSLib::getAppDir( 'videos' ) . "/sources/functions.php" );					    
						    $this->registry->setClass('video_functions', new classVideos( $this->registry ) );
			 print $this->registry->getClass('video_functions')->global_block();
?>

 

Sidebar Type Hook

<?php
			 require_once( IPSLib::getAppDir( 'videos' ) . "/sources/functions.php" );					    
						    $this->registry->setClass('video_functions', new classVideos( $this->registry ) );
			 print $this->registry->getClass('video_functions')->video_block();
?>

 

Go in Admin CP > Other Apps dropdown > Portal > Manage Blocks > Add Block. In the Block Code, just add one of the above.

Share this post


Link to post
Share on other sites

>_> then obviously it will have more delays, so take ur time, while I thorougy check the previous version for bugs and suggestions.

 

Yes more then likely. I like to get the IPB updates out ASAP, there everything will be put on hold while I'm doing this.

Share this post


Link to post
Share on other sites

Would it be possible to add this idea?

You see how the forums are able too use this:

1oMSv.png

 

The result if yes would lead them to seeing the "video titles" but when they click in the video they wont be able access the video.

So they are able to see the video title and everything:

510a877ce6414415944177d.png

 

But when they click any one of them thy get this page:

c138b739f1274bf696c8be9.png

Share this post


Link to post
Share on other sites
Saved as a suggestion, should be included.

I see u upgraded to the latest version :| - make sure you get their editor patch they had, and if u need help wit something just tell me. And thx for including the suggestion, it would save me the hassle of me making a mod for bots to scavenge the videos.

Share this post


Link to post
Share on other sites
Wasn't aware there was an issue, is it present on the forums now? I downloaded a very recent version of IPB before upgrading.

It's an editor patch, it's not rolled with the 3.4.1 version, but is going to be implemented in the 3.4.2 version. You can get it here:

http://community.invisionpower.com/resources/guides.html/_/knowledge-base/341-editor-parser-updates-r262

it fixed quite a lot of bugs i had.

Share this post


Link to post
Share on other sites

Would it be possible to add this idea?

You see how the forums are able too use this:

1oMSv.png

 

The result if yes would lead them to seeing the "video titles" but when they click in the video they wont be able access the video.

So they are able to see the video title and everything:

510a877ce6414415944177d.png

 

But when they click any one of them thy get this page:

c138b739f1274bf696c8be9.png

 

 

Can this be extended to the Global Videos Box and Members box, because guests cant see the the thumbnails and link.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...