Jump to content
DevFuse Forums

Ken Grubb

Customers
  • Content Count

    9
  • Joined

  • Last visited

About Ken Grubb

  • Rank
    Newbie

Previous Fields

  • IP.Board Version
    IPB 4.x.x

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I reverted the template and tested, no change. Then I replaced the code, still no change. I'll send you a PM...
  2. Sorry Michael. I must have... because now I have a different effect. I made the change again, then went to one of the forms and selected white for the background color, then clicked "Save." Then I reloaded the form. The instructions have reappeared, but now the background is a dark grey and the text is black. Note: The H2 headings are blue, since I have them set to be blue in custom.css, if that makes any difference. Here's the code after I changed it, copy and pasted it below: {{if \IPS\Dispatcher::i()->application->directory === 'form'}} <ul class="ipsToolList ipsToolList_horizontal ipsResponsive_hidePhone ipsClearfix"> {{if member.group['g_fs_view_logs']}} <li class='ipsToolList_primaryAction'> <a class="ipsButton ipsButton_medium ipsButton_important ipsButton_fullWidth" href="{url="app=form&controller=logs" seoTemplate="form_logs"}"> {lang="view_logs"} </a> </li> {{endif}} {{if !settings.fm_require_form}} <li class='ipsToolList_primaryAction'> <a class="ipsButton ipsButton_medium ipsButton_important ipsButton_fullWidth" href="{url="app=form&do=formlist" seoTemplate="form_list"}"> {lang="show_forms"} </a> </li> {{endif}} </ul> {{endif}} {{if \IPS\Dispatcher::i()->application->directory === 'form'}} {template="pageHeader" group="global" app="core" params="$container->_title"} {{else}} {{endif}} {{if $container->formTranslate( 'rules' )}} <div class='ipsMessage ipsMessage_{{if isset( $container->_options->rules_color )}}{expression="$container->_options->rules_color"}{{else}}info{{endif}}' {{if isset( $container->_options->rules_color ) AND $container->_options->rules_color == 'none'}}style='color: #000;'{{endif}}> {$container->formTranslate( 'rules', TRUE )|raw} </div> {{endif}} <div class='ipsBox ipsPad'> <div class='ipsType_normal ipsType_richText'> {$form|raw} </div> </div> Here's the effect:
  3. Hi Michael, Sorry I didn't catch this, I forgot to subscribe to this. I added the patch as you explained. The background is now white, but the text is also still white. Also, the form instructions have completely disappeared. Not just because of white text, the form instructions are completely gone. Have a look at the attached screenshot... There is supposed to be a few paragraphs of instructions (in black) above the form fields, but they're no longer there.
  4. In the form instructions section for setting up a form, it offers the choice of a white background. Which would imply a black font color. But when I choose it, I get a black background and a white font. In the next version, would you please fix this so I can have a white background with black font color when I choose the white background option? Many thanks for this application, it's excellent! Ken Grubb
  5. I just bought the News application. When I try to edit the default category to change the name, I get this error: Sorry, you do not have permission for that! 2S119/1 The CSRF protection key did not match. This may indicate a plugin or theme is out of date. Please contact technical support for more information. I disabled all other third-party applications to see if one of them was causing the problem, but I still the error message. I opened a ticket with Invision Power and explained the problem. They said that if I'm getting the error message when only the News application is enabled, then it's an issue with the News application and that I had to contact the developer. What can I do to fix this?
  6. I think this must be a bug though... under the different color blocks, it's says it changes the background to that color. And it works for all of them except the white option. When I click the white option, it makes the background black, not white. I successfully fixed this before using custom.css... I'll try that again now that I know the class involved. Perhaps that will over-ride it. I'll also see if I can make the change as you suggest. With respect, I'd like to suggest in future updates an option to make the form with a white background and black text just as it is on pages everywhere else. Thanks again, Michael!
  7. I need to add information about the service the customer will be buying on the form above the form fields. I also need to add a photo there. The only way I can see to do this is by entering the information in the "Form Rules" section. I'd like this section to look like the rest of my site, with a white background and black text. But apparently I can only select various colors for the background, with white text. Is there a way to change this to a white background and black text? If I have to use the custom.css style sheet in the templates section of Admin, what are the IDs or classes of the things I need to change? I tried using Firefox's Inspector but I can't figure it out.
  8. Ah! No I don't. I didn't know that setting existed. Thanks very much, Michael!
  9. I recently upgraded Forms on my site. I've been under spam attack for the last week by a spambot using the contact form as a guest. I logged in as a guest and saw that the Captcha wasn't appearing for guests. It is appearing for members of all categories, but not for guests. I checked the form settings and the guest group permissions, and both are set to NOT bypass Captcha. I deleted the contact form and created a new one hoping the new build would fix the problem. But again, when I log in as a guest, Captcha doesn't appear at all. How can I get the Captcha to appear for guests using the contact form?
×
×
  • Create New...