Jump to content
DevFuse Forums
  • Error on Approving or Hiding a video


    steve k.
    • Pending IP.Board Version: IP.Board 4.4.x

    When hiding a vide, received the following error. I think i received the same error when Approving the video content also. The actual task of hiding the video still happened.

     

    Sorry, there is a problem
    
    Something went wrong. Please try again.
    Error code: EX0
    
    This error was probably caused by application Videos.
    If the issue persists, disable it and contact the author for further assistance.
    ArgumentCountError: Too few arguments to function IPS\forums\_Topic::hide(), 0 passed in /home/skupper/www.bmw2002faq.com/applications/videos/sources/Video/Video.php on line 1248 and at least 1 expected (0)
    #0 /home/skupper/www.bmw2002faq.com/applications/videos/sources/Video/Video.php(1248): IPS\forums\_Topic->hide()
    #1 /home/skupper/www.bmw2002faq.com/system/Content/Content.php(1055): IPS\videos\_Video->onHide(NULL)
    #2 /home/skupper/www.bmw2002faq.com/system/Content/Item.php(2158): IPS\_Content->hide(NULL, '2 of the same v...')
    #3 /home/skupper/www.bmw2002faq.com/system/Content/Content.php(796): IPS\Content\_Item->hide(NULL, '2 of the same v...')
    #4 /home/skupper/www.bmw2002faq.com/system/Content/Controller.php(864): IPS\_Content->modAction('hide', NULL, '2 of the same v...')
    #5 /home/skupper/www.bmw2002faq.com/system/Dispatcher/Controller.php(85): IPS\Content\_Controller->moderate()
    #6 /home/skupper/www.bmw2002faq.com/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
    #7 /home/skupper/www.bmw2002faq.com/init.php(820) : eval()'d code(16): IPS\Content\_Controller->execute()
    #8 /home/skupper/www.bmw2002faq.com/applications/videos/modules/front/videos/view.php(34): IPS\Content\templates_hook_TemplateController->execute()
    #9 /home/skupper/www.bmw2002faq.com/system/Dispatcher/Dispatcher.php(152): IPS\videos\modules\front\videos\_view->execute()
    #10 /home/skupper/www.bmw2002faq.com/index.php(13): IPS\_Dispatcher->run()
    #11 {main}

    The video that was hidden

    https://www.bmw2002faq.com/videos/view-295-update-on-the-2002-resto-mod/

     

    The video that was approved 

    https://www.bmw2002faq.com/videos/view-301-bmw-neue-klasse-manufacturing/

     



    User Feedback

    Recommended Comments

    Also, approving the video did not approve the topic in the forum. 

    Topic in the forum was created under proper username, but the post is created as guest. 

    The videos were both pulled through RSS from YouTube

    Share this comment


    Link to comment
    Share on other sites

    Confirmed bug.

    Manual Patch

    Open applications/videos/sources/Video/Video.php

    Find:

    $topic->hide();

    Replace With:

    $topic->hide( $member );

    Find:

    $topic->unhide();

    Replace With:

    $topic->unhide( $member );

    Save.

    Share this comment


    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

    Pending = We are still working on this report.

    Fixed = The issue has been fixed and the resolution will be available in the next version.

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

×
×
  • Create New...