Jump to content
DevFuse Forums
  • Error with deleting pics


    cybernck
    • Fixed IP.Board Version: IP.Board 4.2.x

    I get this error when I tried to delete (someone else's) garage photo:

    Sorry, there is a problem

    Something went wrong. Please try again.

    Error code: EX0

    This error was probably caused by application Collections.
    If the issue persists, disable it and contact the author for further assistance.

    BadMethodCallException:  (0)
    #0 /x/public_html/system/Content/Controller.php(779): IPS\Content\_Item->container()
    #1 /x/public_html/system/Dispatcher/Controller.php(85): IPS\Content\_Controller->moderate()
    #2 /x/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
    #3 /x/public_html/applications/collections/modules/front/collections/image.php(32): IPS\Content\_Controller->execute()
    #4 /x/public_html/system/Dispatcher/Dispatcher.php(146): IPS\collections\modules\front\collections\_image->execute()
    #5 /x/public_html/index.php(12): IPS\_Dispatcher->run()
    #6 {main}

    The pic got deleted but none other was set as default (there's one that has the flag but it doesn't work).



    User Feedback

    Recommended Comments

    Default photo fix:

    PHP Fatal error:  Class 'IPS\collections\Item\IPS\collections\Item' not found in /x/applications/collections/sources/Item/Image.php on line 81

    Replace line 81:

            return IPS\collections\Item::load( $this->item_id );

    with

            return \IPS\collections\Item::load( $this->item_id );

     

    Share this comment


    Link to comment
    Share on other sites
    Quote

    I get this error when I tried to delete (someone else's) garage photo:

    Can you try this and let me know how it goes?

    Open applications/collections/sources/Item/Image.php

    Find:

        /**
         * @brief	Title
         */
        public static $icon = 'item';

    Add BELOW:

        /**
         * Get image container
         */
        public function container()
        {
            return $this->imageItem();
        }

    Save.

    Share this comment


    Link to comment
    Share on other sites

    What the... I could swear it wasn't there, I even tried searching for "Title". Spooky :-).

    Yes. That seems to have done the job!

    I can't believe no-one has ever tried to change a default image or delete one (from the image list panel anyway).

    Thanks.

    Share this comment


    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

    Pending = We are still working on this report.

    Fixed = The issue has been fixed and the resolution will be available in the next version.

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

×
×
  • Create New...