Jump to content


Welcome to DevFuse Forums


Sign In  Log in with Facebook

Create Account
Welcome to DevFuse Forums, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of DevFuse Forums by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.
 
Guest Message by DevFuse

(View All Products)Featured Products

  • Donations


    Help fund your forum with donations, setup goals and track member donations. Offer rewards for members donating.
  • Timeslips


    Have your members submit their race times and share with others.
  • Videos


    Allows your members to submit their own videos for community viewing. Support is included for all the major video sites.
  • Forms


    Build your own forms for your members without coding experience. Support included for pm, email and topics.
  • Collections


    Build a community database of items for your members. Full features custom fields included.

Photo

[IPS News]IPB 2.1.5 Released


  • Please log in to reply
2 replies to this topic

#1 Michael

Michael

    Management

  • Management
  • 3,524 posts
  • Gender:Male
  • IP.Board Version:IPB 3.4.x

Posted 01 March 2006 - 06:23 AM

Invision Power Services, Inc. is pleased to announce the release of Invision Power Board 2.1.5 for immediate download.

Invision Power Board 2.1.5 is a maintenance release and includes 50 bug fixes as well as support for Parachat v7.

UPGRADING

Invision Power Board comes with full instructions for upgrading. If you're upgrading a version 2.x Invision Power Board, simply upload all the relevant files listed below (or all files if you're upgrading from any version other than 2.1.4) and access the upgrade system which can be found in "upgrade/" on your board (example: www.domain.com/forums/upgrade/). Follow the instructions to complete your uprade.

If you wish for our technicians to perform your upgrade, please request an upgrade from your client center. Please allow an extra two business days for your upgrade to be performed due to the extra volume a new release makes.

DOWNLOAD THE FULL VERSION

Invision Power Board is available for download in your Client Center -> Your Purchases -> Invision Power Board

DOWNLOAD THE IPB 2.1.4 to IPB 2.1.5 UPGRADE PACK

If you are currently running IPB 2.1.4, we have prepared an upgrade pack for you. Make sure you're logged into your client center and then go to the download page to download the IPB 2.1.4 to 2.1.5 upgrade pack.
Once downloaded and unzipped, upload the files over the relevant files on your server replacing them. Once all the files have been uploaded, access the upgrade system as normal (www.domain.com/forums/upgrade/).

CHANGED TEMPLATES (IPB 2.1.4 -> IPB 2.1.5)

http://forums.invisi...pe=post&id=9867

BUGS FIXED (IPB 2.1.4 -> IPB 2.1.5)
  • [ACP] If your ACP session times out, and you click on a template group, or template bit, you are redirected back to that page after logging in without the ACP wrapper
  • Using the search engine, members can read invisible posts and topics if the Mode is set to Manual, or is set to Full Text, with Advanced Method enabled.
  • Secondary member groups not honored for forum and topic tracker emails
  • API - member information is reset by the topics/posts API, can cause problems if API is used from within IPB source files where member information needs to be checked again later
  • My Assistant does not close properly if you do not have access to view the board
  • Admin logs show login name instead of display name
  • Submit button does not work in Firefox if you hit the back button on a form
  • Renaming an emoticon folder in the ACP causes the emoticons not to show up on the post screen
  • Users are able to post new topics to root categories (even though setting indicates they should not be able to)
  • Subscription Manager currency editor only allows up to 3 digits before the decimal point
  • Certain conditions can cause regex sql to print bad html
  • Hardcoded text
  • Smilies always insert at end of fast reply area
  • [RTE] IE - insert list does not work properly as of 2.1.4
  • [RTE] PHP variables used in the fast reply result in a regex error
  • Settings page sets all field types to 30 for input fields (instead of text)
  • Bad upload url getting inserted on install
  • Avatar setting under User Profiles is not used anylonger
  • Deleting a forum assigned to an RSS import causes a bad entry in the forum cache
  • [ACP] Number of registered members count does not update when adding a member from the ACP
  • open_basedir can produce php warning on some php versions if load limit is to be checked
  • [ACP] Changing the last registered member's name/display name does not update the stats
  • With force login enabled, the http_referer is not set, and users are not redirected back to the page they requested
  • [RSS] Some php versions returning inaccurate times for RSS imported articles if feed does not supply the time
  • Rebuild tools not running on the correct number of items at a time
  • Lost password form will not allow you to complete request if Script/Bot control is set to 'None'
  • RTE - Multiple font tag attributs (i.e. size and color) get nested into one tag and one value is not honored as a result
  • Doublequotes used in the prefix/suffix field when editing a group cause the form field to break
  • Max email length was increased, however the DB column was not updated in 2.1.4
  • Apostrophe's are converted to html entities when clicking 'More Options' from the Fast Reply
  • HTML used for table header in Messenger functions causes a small second th row
  • Personal photo popup window not dynamically sized, can result in scrolling
  • Minor javascript error in the pm card popup when logged in as a guest
  • Only one calendar event per day showing in forthcoming calendar events on board index
  • Inconsistent HTML used for profile view
  • Unterminated html tag for smilie table
  • Approving/unapproving posts from within a topic, the moderator action is not logged
  • Task Manager goes to top of page when you click link to see Cron CURL code
  • Minor typo in ipb_settings.xml
  • Forum inline moderation - 'With Selected' defaults to 1 if no topics selected
  • no_reg variable evaulated instead of being set in index.php when board is offline
  • UTF-8 charsets double decoded incorrectly when using AJAX
  • New ACP restrictions against Admin Splash page undesirable for some users - added a new perm key specifically for Admin Splash page
  • System javascript error in IE6 when using AJAX if using Russian character set
  • Some of the index.html files are outdated (refer to free copy of IPB)
  • 0 byte index.html file causes upload issues with some FTP clients
  • SQL error for specific versions of MySQL using specific filtering options on forum view (ambiguous column error)
  • Email topic emails not applying email settings properly
  • Profile does not show anoynmous user location if group has ability to view anonymous users
  • Contact member emails not applying email settings properly
CHANGED FILES (IPB 2.1.4 -> IPB 2.1.5)
  • cache
  • lang_cache
  • en
  • acp_lang_acpperms.php
  • lang_error.php
  • lang_profile.php
  • lang_subscriptions.php
[/list][*]index.php
[*]ips_kernel
  • class_api_server.php
  • class_communication.php
  • class_email.php
  • class_rss.php
  • class_xml.php
  • class_xml_rpc.php
[*]jscripts
  • ipb_editor.js
  • ipb_editor_rte.js
  • ipb_editor_std.js
  • ipb_forum.js
  • ipb_global_xmlenhanced.js
  • ipb_poll.js
  • ipb_topic.js
  • ips_menu.js
[*]retail
  • chatauth.php
[*]skin_acp
  • IPB2_Standard
    • acp_js_skin
    • ips_menu_html.js
  • acp_skin_html
    • cp_skin_taskmanager.php
  • iframe.html
[*]sources
  • action_admin
    • calendars.php
    • emoticons.php
    • forums.php
    • groups.php
    • index.php
    • login.php
    • member.php
    • rebuild.php
    • rssimport.php
    • settings.php
  • action_public
    • calendar.php
    • forums.php
    • login.php
    • memberlist.php
    • misc
      • forward_page.php
    • moderate.php
    • post.php
    • profile.php
    • register.php
    • usercp.php
    • xmlout.php
  • api
    • api_topics_and_posts.php
  • classes
    • bbcode
      • class_bbcode.php
      • class_bbcode_core.php
    • class_display.php
    • class_session.php
    • editor
      • class_editor_rte.php
    • post
      • class_post.php
      • class_post_edit.php
      • class_post_reply.php
  • components_acp
    • chatpara.php
    • chatsigma.php
    • copyright.php
  • components_public
    • chatpara.php
  • ipsclass.php
  • lib
    • admin_skin.php
    • func_boardstats.php
    • func_usercp.php
    • search_mysql_ftext.php
    • search_mysql_man.php
  • loginauth
    • convert
      • auth.php
    • ldap
      • auth.php
  • sql
    • mysql_admin_queries.php
    • mysql_queries.php
[*]style_images
  • 1
    • folder_js_skin
    • ips_menu_html.js
  • folder_mime_types
    • index.html
  • folder_team_icons
    • index.html
  • iframe.html
[*]upgrade
  • upg_21011
  • *.*
[/list]Source: Click Here

#2 Guest_Nykid232_*

Guest_Nykid232_*
  • Guests

Posted 07 March 2006 - 03:22 AM

I have 2.1.4 should I upgrade right away or is it not nessecary yet?

#3 Guest_majesty_*

Guest_majesty_*
  • Guests

Posted 07 March 2006 - 10:59 AM

If you do not have too many Mods on your board, then you should upgrade it. But if you have too many Mods and not familiar with upgrading, then I suggest you should seeking for expert help.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users